Status
Back
Maintenance
scheduled update
Completed
1 day and 14 hours ago
.
Affected services
Dynamics 365
Completed
Maintenance completed
Posted
1 day and 14 hours ago
.
Started
scheduled update
Posted
1 day and 16 hours ago
.